LibreOffice Calc進階教學:試算表應用篇

pdf
8.97 MB
52 頁
蔡凱如
侵權投訴
加載中. ..
PDF
Libreoffice
辦公應用進階教學
Calc 試算表應用篇
蔡凱如
目 錄
一、初探 Calc 試算表..................................................................................................................................1
1.儲存格資料輸入--多行文字............................................................................................................1
2.儲存格資料輸入--快速輸入............................................................................................................3
3.儲存格資料輸入--日期時間............................................................................................................4
4.儲存格資料輸入--零為首資料........................................................................................................5
二、儲存格資料處理...................................................................................................................................7
1.即時驗證輸入資料...........................................................................................................................7
2.保護文件與工作表...........................................................................................................................8
3.開放局部範圍輸入...........................................................................................................................9
4.隱藏局部範圍資料.........................................................................................................................10
【單元練習】--格式設定.................................................................................................................12
三、選擇性貼上資料.................................................................................................................................13
1.貼上格式化......................................................................................................................................13
2.資料欄列替換..................................................................................................................................15
3.貼至 Writer 文件..............................................................................................................................16
【單元練習】--跨檔案複製貼上....................................................................................................19
【單元練習】--資料的匯入.............................................................................................................19
四、工作表列印設定.................................................................................................................................20
1.縮放列印..........................................................................................................................................20
2.置中列印..........................................................................................................................................22
3.重複標題..........................................................................................................................................23
4.頁首頁尾..........................................................................................................................................24
5.頁面分隔..........................................................................................................................................27
6.刪除斷頁..........................................................................................................................................28
五、工作表管理.........................................................................................................................................29
1.命名工作表......................................................................................................................................29
2.新增工作表......................................................................................................................................30
3.搬移與複製......................................................................................................................................31
4.群組工作表......................................................................................................................................33
5.刪除工作表......................................................................................................................................35
6.隱藏工作表......................................................................................................................................36
7.變更標籤色彩..................................................................................................................................38
六、格式化數字資料.................................................................................................................................39
1.數值格式..........................................................................................................................................39
2.日期格式..........................................................................................................................................40
3.自訂格式..........................................................................................................................................41
七、跨表格運算整合.................................................................................................................................44
【單元練習】--跨表格計算.............................................................................................................45
八、格式化條件應用.................................................................................................................................46
1.新增條件..........................................................................................................................................46
2.修改條件..........................................................................................................................................48
3.刪除條件..........................................................................................................................................50
一、初探Calc 試算表
試算表與一般文件最大的不同,即是它的內容是以表格形態呈現,而每
一格儲存格即為一個編輯區,使用者可輸入文字、數字、日期、符號或
運算式等資料。
在這個單元中,我們透過製作「人事資料表」的範例,向大家介紹儲存
格資料的輸入與處理,接著介紹跨檔案的整合與排版,最後介紹工作表
的檢視與應用,帶領大家瞭解試算表在編輯與檢視上使用技巧。
1.儲存格資料輸入--多行文字
一般報表的設計,不外乎也是從資料輸入開始。大部分資料可透過鍵盤
之主鍵盤區或數字鍵盤區輸入。
在試算表的儲存格中輸入資料,無論是文字或數字,儲存格會放在同一
行中,若沒有特別設定,並不會換到第二行。所謂的「多行文字」是指
在同一個儲存格中,資料以二行或更多行的方式,放置於同一個儲存格
中顯示。
◎標題的多行文字
一般而言,標題若有「大標題」及「次標題」,它們都會一起顯示,此
時我們可以透過手動設定,讓兩個標題放置於同一個儲存格中並分成二
行。
步驟1:將「文字插入點」放置於【A1】儲存格→輸入「大標題」。
步驟2:選按鍵盤【Ctrl】鍵不放→再按下【Enter】鍵,「文字插入點」
會放置於第二行。
1
步驟3:輸入「次標題」,如:【人事資料表】→選按鍵盤【Enter】
鍵,完成文字輸入,即可看到儲存格中呈現二行的文字。
步驟4:選取【A1:I1】儲存格→選按【 】,讓標題可以放在表格中
央位置。
小百科:
鍵盤上「按住Ctrl 鍵不放,再按Enter 鍵」這個動作,一般我們也
稱之為選按【Ctrl + Enter】鍵。
小技巧:
每選按一次鍵盤【Ctrl + Enter】鍵,儲存格中即可多一行。若要取
消多行文字則可按【Delete】鍵或【BackSpace】鍵刪除換行設定。
小百科:
2
◎儲存格內容換行
當試算表內容較多時,我們不可能一個個去儲存格中選按【Ctrl+Enter】
鍵做多行文字設定,此時可以透過格式來幫助我們完成多行文字設定。
步驟1:選取【地址欄】→點選「側邊欄」的【 】圖示→勾選【文
字折行】。
完成後編輯區中「地址欄」的內容,即可分成二行或更多行。
2.儲存格資料輸入--快速輸入
當試算表中出現重覆的資料時,我們可以透過快速輸入的方式,讓儲存
格同時出現相同的資料內容。
步驟1:選取「部門欄」中【欲輸入資料的儲存格】→輸入【業務部】
3
步驟2:選按鍵盤【Alt】鍵不放→再按下【Enter】鍵。
完成設定之後,選取的範圍就會出現「業務部」的字樣。
小百科:
鍵盤上「按住Alt 鍵不放,再按Enter 鍵」這個動作,一般我們也
稱之為選按【Alt + Enter】鍵。
小技巧:
選按鍵盤【Alt + Enter】鍵做快速輸入,只能用在連續的儲存格。
在文字輸入之前,必須要先選取儲存格範圍,文字輸入之後立即按
下【Alt + Enter】鍵即可完成資料輸入。
3.儲存格資料輸入--日期時間
除了文字和數字之外,日期和時間也是試算表中常見的資料。一般而
言,日期的輸入可採用「/」或「-」來區隔,但Calc 試算表中預設是以
「-」標記;而時間則是採用「:」來區隔。
步驟1:在「到職日期」的欄位輸入【1994/10/20】→選按【Enter】鍵。
4
完成之後,到職日期即會改為預設的「1994-10-20」日期資料。
步驟2:在「調查時間」的欄位選按鍵盤的【Ctrl】及【;】鍵→選按
【空白鍵】→再選按【Ctrl】、【Shift】及【;】→按【Enter】
完成之後,調查時間即會顯示的日期與時間,預設的格式為
「2016 年1月5日 13 時50 分」。
4.儲存格資料輸入--零為首資料
一般而言,資料中需要輸入以「零為首」的資料,常見的有編號、電話
及銀行帳號等。但是上述這些資料都是以「數字」組成的,當資料輸入
完成後,選按Enter 鍵結束編輯,最前方的「0」就會消失不見。'
◎編號
以員工編號為例,若要輸入001、002…的值,可以如下步驟設定:
5
步驟1:在第一筆資料處,選按鍵盤【'】鍵→輸入【001 】→選按
【Enter】鍵。
完成之後,儲存格中即可出現以零為首的資料。
小百科:
數值資料一般而言是不會以「零」為首,因此當我們輸入數字資料
時,若以零為開頭,系統即會自動把最前方的「零」刪除。在不影
響儲存格預設格式情況下,建議採用「'」(假文字)的形式,讓零
為首的資料顯示。
◎電話
並不是所有以「零」為首的資料,都要採用「'」(假文字)方式設定,
以行動電話為例,它通常由10 位數字組成,我們也可以透過格式設定
的方式,在數字之間加上連字符號「-」,即可解決該問題。
步驟1:點選【格式】→【儲存格】→在【數值】的『格式碼』中輸入
電話號碼的格式,如:【0000-000-000】→選按【確定】鍵。
完成之後,儲存格中即可出現正確的電話資料。
6
二、儲存格資料處理
資料的輸入雖說是最基礎的,但卻也是最重要的一環。在試算表中輸入
資料,若一不小心輸入錯誤,屆時核對起來可能困難重重,因此儲存格
中資料輸入時的各項處理也是學習的關鍵。
1.即時驗證輸入資料
在試算表中繕打資料時,最怕輸入錯誤而不自知,尤其是數值資料更是
不易察覺,待發現時要再查證也是很費時又費工,此時我們可以透過
「驗證」的功能來幫助我們,在輸入資料的同時檢查資料的正確性。
步驟1:選取「欲設定的儲存格範圍」,如:【身份證字號】。
步驟2:點選【資料(D)】功能表→【驗證(V)...】→點選【條件】標籤→
設定允許為【文字長度】→設定數據為【等於】→設定值為
【10】。
步驟3:點選【輸入說明】標籤→勾選【在選取儲存格時顯示輸入說
明】→設定題名為【請輸入身份證字號】→設定輸入說明為
【身份證字號,內容為10 個字】。
7
步驟4:點選【錯誤警告】標籤→設定動作為【停止】→設定題名為
【資料錯誤】→設定錯誤訊息為【您輸入的身份證字號不正
確,請再檢查乙次】→按【確定】。
完成設定之後,儲存格中若輸入錯誤的資料,選按【Enter】鍵
時,立即就會出現訊息視窗。
2.保護文件與工作表
當試算表的內容完成之後,若不希望被人家任意修改,我們可以將工作
表保護起來,避免有心人竄改資料,造成工作表在參照或跨檔案應用
時,產生計算錯誤的情形。
步驟1:點選【工具】功能表→【保護文件】→【工作表】→設定密碼
為【123456】→【確定】
8
完成之後,工作表中的任何一格儲存格皆無法修改內容。
3.開放局部範圍輸入
試算表的內容,有時某些資料需要由其他人代為輸入,但是我們卻擔心
別人不小心修改到其他儲存格的資料,若將工作表保護起來,則會完全
無法輸入資料,此時我們可以只開放一部份的儲存格讓使用者可輸入,
其他部份則無法編輯。
步驟1:選取「欲開放的儲存格範圍」,如:【地址】、【電話】及
【Email】。
步驟2:點選【格式】功能表→【儲存格】→點選【儲存格保護】標籤
→取消勾選【□受保護】→【確定】。
9
步驟3:點選【工具】功能表→【保護文件】→【工作表】→設定密碼
為【123456】→【確定】
完成之後,在不想被修改的儲存格中輸入文字,電腦會立刻顯
示警告訊息。
在開放輸入資料的儲存格中輸入資料,如:修改電話為【0936-
520-520】,電腦不會顯示任何警告訊息。
4.隱藏局部範圍資料
當試算表的內容由其他人代為輸入時,很有可能將部份隱私或機密的資
料透露予第三者知悉,為了避免發生該情形,我們除了可以開放部份欄
位提供編輯之外,還可以將隱私或機密的資料予以隱藏,避免重要的資
料外洩。
10
步驟1:選取「欲隱藏的儲存格範圍」,如:【出生日期】。
步驟2:點選【格式】功能表→【儲存格】→點選【數字】標籤→在格
式碼輸入【;;;】
步驟3:點選【儲存格保護】標籤→勾選【全部隱藏】→【確定】。
步驟4:點選【工具】功能表→【保護文件】→【工作表】→設定密碼
為【123456】→【確定】。
11
完成之後,儲存格中的資料即會隱藏不會被看見,且因為工作表被保
護,也無法被修改。
【單元練習】--格式設定
開啟「在職訓練班學生選課資料內容」進行下列處理:
1.「學員基本資料」工作表:將學號搬移到A欄。「年齡」欄位:利用
DATEDIF、TODAY 函數計算年齡,格式為「X 歲」。
2.「修課資料」工作表
(1).搬移欄位:將「學員基本資料」工作表中「上課期別」及「班別」
二欄搬移至C、D欄。
(2).複製資料:將「學員基本資料」工作表中「學號」複製到A欄。
(3).排序:按「上課期別」及「班別」遞增排序。
(4).輸入資料:在B1 儲存格輸入「姓名」水平、垂直置中對齊,以
VLOOKUP,依學號搜尋「學員基本資料」工作表姓名資料。
(5).繪製框線:(A1~D120)內框線為1.5pt 實線,外框線為3pt 實線。
(6).填滿色彩:
第一列( A1~D1 ) :天空藍1(Sky blue 1)色彩。
B欄( B2~B120 ) :青色1色彩。
12
三、選擇性貼上資料
在編列試算表時,也許資料的來源是其他的檔案,屆時我們就會使用到
「複製」及「貼上」的功能,將資料匯整到同一份工作表中。而在試算
表中「選擇性貼 」的功能,比起在文件排版軟體的「貼上」功能多了
許多的選項,讓我們在處理資料的同時可以更靈活。
1.貼上格式化
所謂的「格式」是指儲存格中資料的字型、大小、色彩、框線、底色…
相關設定,它無法透過鍵盤輸入,而是經由功能表設定的!
當我們採用「複製」及「貼上」的功能來處理資料時,若想要採用相同
的格式設定,便可透過「貼上格式化」來完成,特別是在「評註」的處
理。
步驟1:將「文字插入點」放置於來源資料的儲存格,如:【張三瑜】
→選按工具列上【 】,將資料複製。
步驟2:選取【欲貼上資料的儲存格】,如:【陳棟驤】。
步驟3:選按【編輯(E)】功能表→【選擇性貼上(S)...】→取消選取內容
中預設勾選的【文字】、【數字】及【日期和時間】→再勾選
【評註(C)】及【格式化(M)】→選擇【◎加】→最後再按
【確定】。
13
完成設定之後,儲存格中即貼上來源資料的評註,但不會變更儲存格原
有之資料。
小技巧:
按住鍵盤的「Ctrl」鍵,可選取不連續的儲存格,一起進行貼上的
動作。
14
?
2.資料欄列替換
當試算表的內容已編輯完成,此時若要將欄和列的資料予以交換,或是
將原先直式的表格轉換為橫式的表格,著實令人傷腦筋!別擔心,在
「選擇性貼上」的選項中即提供好幫手,可以幫助我們快速完成。
步驟1:選取要轉換的資料範圍→選按工具列上【 】,將資料複製。
步驟2:將「文字插入點」放置於資料欲貼上的位置→選按【編輯(E)】
功能表→【選擇性貼上(S)...】→選取內容勾選【全部貼上】
→選項勾選【列欄替換(T)】→【確定】。
15
完成設定之後,儲存格中即將欄和列的部分交換,但不會變更儲存格原
有之資料。
3.貼至Writer 文件
試算表中的資料編輯完成後,有時會在 Writer 文件引用並排版,此時若
直接透過「複製」及「貼上」的方式將資料貼至 Writer 文件,我們會發
現它以圖片物件的型態呈現,對於排版反而造成困擾。
要將資料從試算表中複製到 Writer 文件,有如下二種方式,我們可依需
求採用。
◎格式化文字[RTF]
採用「格式化文字[RTF]」將試算表貼至 Writer 文件中,它會以表格的
型態呈現,排版及編輯方式和 Writer 中的表格是相同的,不過值得注意
的是,當試算表中的資料有變動時,Writer 文件中的資料並不會自動更
新,容易造成資料不同步。
步驟1:選取要轉換的資料範圍→選按工具列上【 】,將資料複製。
16
步驟2:開啟Writer 文件→選按【編輯(E)】功能表→【選擇性貼上】→
選按【格式化文字[RTF]】→【確定】。
完成設定之後,試算表中的資料即複製到文件中,接下來再進行表格框
線設定及排版即可。
◎DDE 連結
試算表貼至 Writer 文件中,當試算表的資料有變動時,而 Writer 文件中
的資料並不會自動更新,造成資料不同步,如此一來反而在修改資料
時,要同時修改二份文件,造成工作上的困擾;此時我們可以採用 DDE
連結,讓二份文件具有同步更新的功能。
步驟1:選取要轉換的資料範圍→選按工具列上【 】,將資料複製。
17
步驟2:開啟Writer 文件→選按【編輯(E)】功能表→【選擇性貼上】→
選按【DDE 連結】→【確定】。
完成設定之後,試算表中的資料即複製到文件中,並且具有同步更新的
功能。
小技巧:
當試算表的資料以「DDE 連結」的方式,複製到Writer 文件中,
它是無法刪除的!若要刪除必須先至【編輯(E)】→【連結】→
【斷開連結】,才能予以刪除。
18
【單元練習】--跨檔案複製貼上
製作一張甘特圖,並將其複製到Writer 文件及簡報文件中。
【單元練習】--資料的匯入
開啟一個空白試算表,並依下列項目進行設定:
1.匯入Unicode 文字檔「會員資料.txt」,工作表名稱為「會員資料」:
*會員編號:設定為文字型態欄位。
*生日:民國日期型態。(匯入時必須是民國日期的資料型態)
*年齡:不匯入。
2.更改地址欄位資料 :
將所有開頭為「北市」改為「台北市」,「台北縣」。
3.刪除所有電子郵件改地址欄位首字元的空白。
4.隱藏年薪欄位的所有資料。
(無論是數值或文字均須隱藏,儲存格內容與資料顯示均須是隱藏狀
態,請使用自訂數字格式與隱藏功能)。
5.將工作表予以保護,設定密碼為「168168」,指定可編輯範圍為
D2~l49、K2~K49,其他都不可編輯。
19
四、工作表列印設定
工作表編輯完成之後,我們可以將它的資料內容列印出來。一般情況
下,試算表在列印時會以整張工作表為列印範圍,但卻不一定符合實際
的需求,故我們可以視情況採用不同的設定,讓列印出來的報表更符合
需求。
1.縮放列印
縮放列印是指在不影響原文件內容大小的情形下,更動試算表列印出來
的大小比例。此功能適用於大範圍的文件,欲縮小列印並指定的頁數時
採用的設定。
◎手動設定
步驟1:點選【檢視(V)】功能表→【斷頁預覽】→將【游標置於分頁
處】→將【分頁標記向右拖曳至最末筆資料右方】。
完成設定之後,系統會自動調整列印的比例。
20
◎系統設定
步驟1:點選【格式(O)】功能表→【頁面(P)】→點選【工作表】標籤
→設定「顯示比例」為【使列印範圍合寬度/高度】→設定「寬
度頁數」為【1】→設定「高度頁數」為【3】→【確定】。
完成設定之後,系統會自動調整列印的比例。
小百科:
寬度頁數:指表格的頁面寬度佔用紙張頁數。
高度頁數:指表格的內容長度佔用紙張頁數。
21
2.置中列印
工作表預設的版面是靠左對齊,因此列印時右半部會有較大的空白處,
影響版面配置的美觀,此時我們可以設定版面的對齊方式,使工作表置
於文件中央,讓版面較為美觀。
步驟1:點選【格式(O)】功能表→【頁面(P)】→點選【頁面】標籤→
設定「表格對齊(G)」為【橫向】→【確定】。
完成設定之後,工作表在頁面即會呈現水平置中。
22
3.重複標題
一份正式的報表,每一頁的資料都需要有標題,但工作表內容需使用多
頁列印時,預設僅有第一頁會出現標題,此時我們可透過「列印範圍」
的設定,讓每一頁的報表皆帶有標題。
步驟1:點選【格式(O)】功能表→【列印範圍(N)】→【編輯(E)...】→
點選「要重覆的列」右方的【 】收縮鈕
步驟2:選按工作表的【列】→再選按【 】擴展鈕。
步驟3:選按【確定】。
完成設定之後,工作表列印時,每一頁最上皆會帶有標題。
   
23
4.頁首頁尾
在Writer 文件中要編輯頁首及頁尾,必須進入頁首及頁尾的編輯區;而
在Calc 試算表中,頁首與頁尾的區域已預先設定在工作表頂部與底部以
外的區域,無法從工作表中窺視,必須透過預覽列印才能一探頁首頁尾
的盧山真面目。
◎頁首
「頁首」通常出現在頁面的上方且位於上邊界之外,一般是顯示標題、
工作表標籤或檔案名稱等資訊。
步驟1:點選【格式(O)】功能表→【頁面(P)】→點選【頁首】標籤→
勾選【顯示頁首】→選按【編輯】。
步驟2:選按【 】,顯示工作表名稱,如:【員工資料一覽表】→
【確定】。
步驟3:選按最下方的【確定】。
24
完成設定之後,報表即會在頁面右上方顯示工作表的名稱。
◎頁尾
「頁尾」一般出現在頁面下方且位於下邊界之外。典型的情況是顯示頁
碼、總頁數或列印時間等資訊。
步驟1:點選【格式(O)】功能表→【頁面(P)】→點選【頁尾】標籤→
勾選【 顯示頁尾】→選按【編輯】。
步驟2:選按【 】,設定顯示的資料,並輸入所需的文字,如:
【第1頁】→【確定】。
25
步驟3:選按最下方的【確定】。
完成設定之後,報表即會在頁面下方中央顯示頁碼。
◎背景
試算表中若要在列印時,讓每一張工作表都加入背景,必須到頁面格式
進行設定。要留意的是背景圖片的大小和色彩必須先處理,在試算表中
僅能調整其出現的位置,無法設定圖片的大小和效果。
步驟1:點選【格式(O)】功能表→【頁面(P)】→點選【背景】標籤→
【圖形】→【瀏覽】。
步驟2:選按【所需的圖片】→【開啟舊檔(O)】→設定「類型」為
【◎位置】→【置中】→選按【確定】。
26
完成設定之後,每一張報表在頁面中央即會顯示背景圖。
小百科:
背景圖的位置會依每張工作表的資料多寡而調整其置中的位置。
5.頁面分隔
一般多頁工作表在列印時,系統會自動分頁,但若使用者希望能自行規
劃每一張工作表資料列印的筆數,此時就必須要透過手動設定,方可符
合需求。
步驟1:將「游標放置於欲分頁的儲存格位置」,如:第21 筆資料。
步驟2:點選【插入(I)】功能表→【斷頁(B)】→【斷列(R)】→依序在
第41 及61 筆資料【重覆步驟2的動作】。
27
完成設定之後,每一頁的工作表即僅有20 筆資料。
   
6.刪除斷頁
若要取消使用者自行設定的分頁,我們必須取消斷頁設定,工作表才能
恢復自動分頁的列印方式,否則每次工作表在列印時,皆會採用先前使
用者設定的筆數作為分頁依據。
步驟1:將「游標放置於欲取消分頁的位置」,如:第21 筆資料。
步驟2:點選【編輯(E)】功能表→【刪除斷頁(B)】→【斷列(R)】→依
序在第41 及61 筆資料【重覆步驟2的動作】。
完成設定之後,工作表即恢復自動分頁的設定。
   
28
收藏 ⬇️ 下載